Macromedia Dreamweaver 8 || English 510 || Fall 2006

Important: Before going through this handout, you should create a WWW directory on your ISU e-mail account.
Otherwise, you will not be able to upload and view the pages you will create as part of this handout. To check
whether you have a default homepage, open a web browser and type in the following:
http://isulD.public.iastate.edu/, e.g., http://volkerh.public.iastate.edu/ .

Please follow the instructions on our syllabus to create a default homepage through Acropolis. Be sure to
register your homepage after you have created it!

Introduction

Macromedia Dreamweaver is a WYSIWYG (What You See Is What You Get) editor used for web
page creation. This handout will guide you through the first use of Dreamweaver 8. Please keep it
handy for future use. Unless you have already spent a bit of time developing web pages, the next 3-5
weeks will be rather intense and time-consuming. In addition to learning more about web page
design and development, | have found that it takes a while to conceptualize and integrate this new
knowledge with the new knowledge you will gain about the inner workings of the WWW, files,
folders, and file types. Therefore, | will make myself available to you and allocate a good number of
hours to help you as best I can (electronically, that is, until I get back from Spain). However, the most
important part in this unit is that you spend time working with the application and practicing
everything you learn outside of class. Be sure to allot time (extended periods of time work better,
based on my experience) to work and play with Dreamweaver (or any other web development
application you choose).

Assignment

In addition to the work we will be doing in class, read the assigned chapters in the required books for
English 510 (see our syllabus for the exact chapters in Niederst and Sawyer McFarland to read) and
work through the following parts of the Macromedia Dreamweaver help pages, which you can access
within Dreamweaver through Help > Using Dreamweaver (or by pressing F1):

» Dreamweaver Basics

» Working with Dreamweaver Sites.
» Laying out Pages

» Adding Content to Pages

Note: You are encouraged to work through the tutorials available as part of Dreamweaver 8 and, if
interested, also through the ones available on the Macromedia website. Everything covered in class, in
the four Help units mentioned above, and in the assigned readings is fair game for skill consolidation
exercises.
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Overview: You will be completing the following steps:

Step 1: Opening the Dreamweaver 8 and creating a basic web page

Step 2: Setting up a local site

Step 3: Inserting hyperlinks

Step 4: Inserting images

Step 5: Considering file management options

Step 6: Uploading pages to the ISU public server

Step 1: Opening the Dreamweaver 8 and creating a basic web page

Open Dreamweaver 8. You
will see a number of screens
open up. Focus on the main
screen (Fig. 1). Click on
HTML under Create New the
center panel of the center
screen to create a new HTML
page. This will open up a new
document (tentatively named
Untitled-1). Type in some
relevant content, i.e.,
information you would like to
include in your web page. | do
not recommend including any
information that is too
personal, such as your home
phone number, home address,
etc. In order to apply
formatting to text, select the
text (i.e., highlight it) and click
on one of the options in the
Properties window (Fig. 2).
You can designate (under
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Fig. 1: Initial view of Dreamweaver 8
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Format) whether the text is a paragraph, a heading, or preformatted text. The pop-up menu below
(Font) lets you pick your favorite font and the box next to it allows you to specify the font size. Other
options include changing the color, type-face (bold or italics) and justification. Other buttons below let
you create numbered or bulleted lists and insert or remove indentations. Important: Please do not
“play” with formatting too much since we are going to try to separate content from form through the
use of cascading style sheets.

ii ¥ Properties =
FormatINone j StvleINone j 55 | B|I|§|§|§|§| Linkl VI@J %
Fontlm Sizel jﬂ| EE|§: §|§|Targetlﬁ
| [Page Properties. .. ] [ List Item. .. ]
Fig. 2: Properties window
Changing Page Properties x4
Caktegory Appearance I
On the menu bar, select Modify> Page i roas et |Defauk Fot il
Properties or click on Page e I e | b=
. . - - Text color: Ql—
Properties... in the Properties Window. et [
You can now change the appearance of seckpardiness [ —
the entire page by specifying the default wepests [——3]
font, font size, text color, and
background color of the page (under eftmargn: [ [ - Rishemerams [ ook <]
Appearance) YOU Should add a Top margin: l—lpixels 'l EBatkam margin:l—lpixels 'l
document title under Title/Encoding
(pleas_e use something a bit more _ T ] e | o | e |
descriptive than my homepage). At this

point, please do not worry about Figure 3: Page Properties

applying a background image or a

tracing image. You can also specify the

color of the text, links, visited links, active links, and margins. Unless you plan to use a non-western
language, do not change the setting for document encoding. When done, click OK. To preview what
the page will look like, press Apply. You should now have a basic page with some text on it. The next
step is to look at the page through a browser (e.g., Microsoft Internet Explorer, Netscape Navigator,
Mozialla Firefox, Opera, or Safari). To do that, you can select File > Preview in browser (specify the
browser you want) or simply hit F12. This process can be repeated, i.e., as you type in more
information you can periodically preview your web page.

Note: Please do NOT spend a lot of time playing with the font attributes and with the color options as
we will make use of cascading style sheets (CSS) to control the appearance of your web pages. Itis
important to separate the content of your web page from the formatting.

To facilitate the entire web page creation process, the next step is to set up a Site.
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Step 2: Setting up alocal site

For Dreamweaver to keep track of your files and to update links automatically, you need to set up a
site. The following procedure is very important because it will help you conceptualize the relationship
between viewing documents locally (through a browser) and viewing documents on the World Wide
Web (where anybody with access to the Internet can view them).

Dreamweaver has an excellent site management feature, which we will be using extensively. This
feature allows you to designate a local folder on your computer (or on a removable drive such as a
USB Flash drive) in which you save and store your web pages and associated assets (e.g., images).
Since the computers in Ross 312 are open to the public and are rebuilt on a regular basis, you should
not keep your personal files on the computers in our lab. Rather, you should keep your files on a USB
Flash drive so you have your files with you at all times. The web server we will be using to store the
files is ISU’s public server. Please see p. 29 in Sawyer McFarland for more info regarding folders.

Note: If you are going to use a different server, it is your responsibility to find out how to access it.

To begin with, you will be telling Dreamweaver which folder is to be treated as the local folder (i.e.,
the one on your flash drive).

Follow these steps to set up a site: x
Basic  Advances
Category Local Infa %
> Start up Dreamweaver, click on Remote nfo _
N X Testing Server Site name: | 510F)6_SITE

Cloaking

Site > Manage Sites, select N

NeW and then Click on the 2.?5i|g\,1n ET_teys t ocal root Folder: |ERLAPTOP'|,My DocumentsiwawiS10F0EY |

' :: i:w aOL?;ns IV Refresh local file list autamaticall
Advanced tab. Under Local Info, Covrbse '

Templates Default images folder: | fim]

give your web site a name
(home, for example). Then click
on the yellow folder button next

Links relative to: ' Document ¢ Site root

HTTP address: I http:ff

This address is used for site relative links,

to “Local root folder” and kst ref to o emske
navigate to your removable Case-sensitive links: [~ Use case-sensitive link checking
storage (i.e., USB Flash drive). Cache: V' Enable cache

Either select a folder you want to ormabon i ske. This e upthe
use as the local folder or create a g TSI SIS

new folder you want to use as the
local folder for your web site.
You can leave the default images
folder empty (Fig. 4).

» Click OK

OF I Cancel Help
Figure 4: Defining Sites, Local Info

Note: Initially, there will not be many
files and directories simply because you have not uploaded any. As the semester progresses, you will
continue to add files and directories to your WWW directory. Only the files and directories inside the
WWW directory are accessible via the World Wide Web. | recommend always working on the local
files first and to upload them only after you are happy with the pages.
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Saving and Viewing Your Document

Now you are ready to save your document. Select File > Save and save your document into the
directory you created (e.g., www, or home) on your USB Flash drive. Use all lower case and no spaces
or special characters. | will talk more about file naming conventions during class. Next, select File >
Preview in Browser > iexplore (or hit F12) to preview your document.

The beauty of the web is its hypertextual nature, i.e., the ability to link to other files, and also its ability
to display multiple types of media. In the next step, you will learn how to include hyperlinks.

Note: You may have to go through this procedure frequently since several students are using the lab.
Additionally, you may not work on the same computer every time you come to class. In other words,

memorize this procedure or have this handout with you so you can set up your site quickly.

Step 3: Inserting hyperlinks

Hyperlinks are links to other documents one can follow
while browsing the WWW. Figures 5 and 6 illustrate
how to insert an (absolute) link, i.e., a link to an outside
web page. Type in the text you would like to be
“clickable,” highlight it (Fig. 5), then type in the URL in
the Link box in the Property window (Fig. 6) and press
enter or click outside of the link area. For example, you
could type lowa State University in your document, then
highlight it and type http://www.iastate.edu in the link = e
area of the property window. To double-check whether | Figyre 5: Highlighting the link text
it works, preview the document in a browser and click

on the link.
e e  [E T
Link [Fetpiremisstate edu Sl i Tme[ ] 535 52
(e ]

Figure 6: Inserting a hyperlink

Absolute and Relative Links

Links can either be absolute or relative. An absolute link is a complete URL, often including the path
and the file that is being linked, e.qg., http://www.iastate.edu/path/file.ntml. A relative link, on the other
hand, is a link to a document that is usually located on your server (and in your www directory). I’ll
demonstrate how to link to files in class and in the online tutorials.
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Note: Whenever possible, you should use relative links, especially with pages in your www
directory, because once you move an entire website, relative links will still work, while absolute
links to files in your directory won’t.

Linking to documents

Some of your assignments will be actual web pages, which means that you can simply link your
assignments using a relative link as described above. However, some of your assignments will be
documents in a different format, such as Microsoft Word, for example. Linking MS Word documents
IS in essence the same as linking html documents. The only difference is that a web browser knows
what to do with an html document, while it may or may not know what to do with an MSWORD (or
.doc) document, in which case it will prompt the user to either save the document or to select an
application with which to open the unknown document.

Page Layout

Macromedia Dreamweaver allows you to design your page by creating a page layout in layout mode.
Please refer to the demonstration in class and the assigned readings for more information about this
option.. Click on the tab Layout, make sure you are in Layout View and click on the Draw Layout

Table (Fig. 7).
Then, draw a ¥ Insert Common Layout Forms | Text | HTML | Application | Flash elements | Favorites |
layout table on Standard |Expanu:leu:| |La1fnut = | e £ = -

the document. :
To subdivide Figure 7: Layout Mode

the layout
table, select the Draw Layout Cell (the blue-bordered button) and draw cells in which you want to add
content, text or images.

Step 5: Inserting images

On the conceptual level, you need to understand that an image that is inserted to your local file will
also need to be transferred to the remote site for it to be visible on the web page! Additionally, the
path that tells the browser where the image is needs to be the same. | recommend creating a directory
for your images (e.g., img, or pics, or pix) inside your www directory (i.e., the local folder) on your
zip disk so you always know where the images are located. If you subsequently work on various
projects that require images, sounds, movies, etc, you could create directories for those within your
project folder. Remember, the directory structure needs to be identical on your local disk and on your
remote site.

Be sure to review Chapters 1-6 in Mc Farland and Chapters 9 and14-16 in Niederst. These chapters
include a nice overview of the file types available to you for display on the World Wide Web. Issues
of particular importance with regard to images on the WWW are:
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e Quality
e File size, file type
e Dimensions

Obtaining/Creating Images

The easiest way to get images is to download (or copy) them off the WWW -- right-click (Windows)
or control-click (Mac) on the image and save it to your disk. You can also scan in photos and use
those on your web pages. A third way would be to create an image using a graphics application, such
as Adobe Photoshop or Macromedia Fireworks.

Note: Observe copyright laws! | recommend keeping track of where you get images so you can ask for
permission to use them in later projects.

Cropping & Resizing images Using Adobe Photoshop & Macromedia Fireworks

Please see demonstration in class.

Viewing the underlying HTML source b :am .
2 homepage.him

In order to view the underlying HTML source code, click on the button b img

right below FILE (a button with two blue angle brackets (Code View). b G persondl

You can also click on the button next to it to see how the HTML is
generated while you are typing and applying formatting changes (Code
and Design View).

[ Efi teaching

Fig. 8: Oganization

A Eﬁ classes
Step 5: File management considerations -  [§sto
= [t‘j assignrnents
Preliminary considerations 51Dassignment 1 html
510azzignment 2. html
Before the actual implementation of a web site — or any S 1Dassignment 3. it
computer-based project, for that matter — I recommend S10summaries.html
giving some serious thought to the file/directory structure b 3 projects
in order to maintain a logical, coherent, and transparent b sz
organization. Therefore, it is imperative to determine home page. higd
which components of a project (a web site, in this case) can b CJ ima "
be grouped and hence put into folders (a.k.a. directories). b G DB
Keep the following considerations in mind: b G teaching
> Number of components required Fig. 9: Suggested organization
» Long lists of files (this should be avoided)
» Logical naming conventions
» Scalability: Allowing possibility for future growth is key
» Compromise between relatively easy URLs and good organization
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Hands-On

Background Information: Let’s assume you are to create a (professional) homepage for one of your
classes. Initially, the main purpose of this homepage is to provide your instructor with easy access to
assignments that need to be linked to this homepage. Additionally, you would like to use this web

page as a location where you can put interesting information,
links, and maybe even some more personal information. In
semesters to come, you are probably going to either teach or
work as a research assistant. My recommendation in a case
like this would be to think of the web page you are creating as
a starting point, with many more related web pages to come.
Hence, a file organization as illustrated in (Fig. 8) might make
sense.

Figure 9 illustrates an expanded view the file structure | am
proposing. Here, directories for 510 and 526 have been
created. Additionally, I created an assignments sub-directory
in which the assignments can be stored. Moreover, | included
a projects folder for future use. In some circumstances, it may
be reasonable to create separate images folders for the different
directories, but that depends on how many images you are
planning on using. Initially, one centrally located folder (in the
root directory) is probably sufficient.

i [‘j clazzes
- s
- E‘j assignments

S510azsignment1 . himl
51 0assignment2.himl
510azsignment3.himl
S10summaries.html
harmepage. html
[ G projects
0 526
hamepage. himl
harmepage. html
b G img
b Efi personal
harmne page . html
[ Eﬁ teaching

Fig. 10: Avoiding index browsing

In order to prevent index browsing (which will be illustrated in class), it is advisable to have a file
named in such a way that it is accessed when the root directory is called. In other words, unless you
have a file that is called homepage.html, users are able to look at what else you have in your directory.
For some directories, this may be irrelevant, but if you would like to control what users can access,
index browsing should be turned off. Consequently, arranging your documents and directories as

illustrated in Fig. 10 may make sense.

Note: Index browsing is supported only by certain web servers. The public server at ISU is a

Unix server that supports index browsing.
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Step 6: Uploading pages to the ISU public server

Now that you have created a series of web page, it is time to upload the to the ISU server so they
can be viewed by millions of people in the world.

We will be using a file transfer application called FileZilla to accomplish this.

- Locate FileZilla and start it
- Click on the arrow under “Edit” and select one of the servers (e.g., isual.iastate.edu). FileZilla will
connect to your locker — i.e., storage space available to all ISU students. What is of particular interest
to us is the directory called “WWW.” This is where all files you want to be accessible via the World

Wide Web need to be
stored.

- Double click on the
WWW folder (under
Remote Site) to reveal
what is inside this
folder. For many of
you, there will not be
much simply because
you have not uploaded
anything, but that will
change momentarily.
— Under Local Site
(left side of the
screen), navigate to
your folder on the
local machine (either
on the computer or on
your flash drive).

- Upload either files or
folders you have
created locally.

FZ Filezilla version 2.2.16

File Edit Transfer Yiew Queus Server Help

=o x|

User. I Password:

Part: Quickconnect ‘ 'I

| & [ =/QE D0 @ %R | 2| e
hol

s e.edu
isuad.iastate, edu
isuat.iastate edu
isuaS.iastate edu

Femote Site:

=

Filenarne | F\Ies\zel Filetype Date

Time | Permis

+-{3) PrintHood
i

{4 Recent

i SendTa

Filename  # | Filesize | Filetype | Last Modified | -
=.

=) _notes
i
D101l
Si0iR
[Ch510
[C)510F06
519
526
[
CD99R
|Zheonf

File Folder
File Folder
File Folder
File Folder
File Folder
File Folder
File Folder
File Folder
File Folder
File Folder
File Folder

414/2005 15:1,..
10/11/2005 8:2...

1j21{2005 17:2...
1j21{2005 17:2...
1§21{2005 17:2...,
/28/2006 22:5...
1§31/2005 16:2...
1j8}2006 22:35...
1j21{2005 17:2...
1§21{2005 17:2...,
1J21/2005 17:2... ;| «

23 Folders and 19 files with 57056901 bytes,

Local Filename: | Sizsl Direckion | Remote Filename I Host Status

[Queue: Dbytes @ @
2

- Important: You should NOT overwrite the WWW folder in your locker (on the Remote Site).
Rather, it is important to upload individual files and folders into this folder (or directory).
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